Artikel Blog

Cara Routing Youtube/Streaming ke VPN Tunnel dengan Layer 7 Protocol

Pada tutorial kali ini saya mencoba mengalihkan trafik streaming/youtube ke VPN Tunnel dengan menggunakan Layer 7 Protocol, cara ini juga bisa anda gunakan untuk mengalihkan trafik Youtube/Streaming ke salah satu ISP.

Langkah pertama kita tambahkan dulu koneksi VPN dengan cara ke menu Interface lalu pilih L2TP Client atau koneksi yang lain misalnya PPTP/SSTP kemudian anda tinggal menambahkan domain/IP Server VPN di kolom connect-to dan isi username dan Password dari akun VPN yang akan anda gunakan.

Anda bisa mencoba menggunakan VPN Gratis yang saya sediakan, untuk membuat akun VPN silahkan hubungi ke no whatsapp saya yang tertera di website ini.  Anda juga bisa menggunakan Script dibawah ini untuk menambahkan koneksi VPN. Pastikan server VPN, username dan password sudah anda edit sebelumnya.

/interface l2tp-client
add connect-to=vpn.labkom.my.id disabled=no name=VPN-mikaila password=12345 user=mikaila

Kemudian tambahkan juga Address List IP Lokal (IP Client) dan IP private-lokal, IP Lokal maksudnya IP Lokal yang digunakan oleh client anda, untuk IP Private lokal maksudnya IP Private yang menjadi pengecualian yang tidak dimasukkan ke address list.

Kemudian tambahkan sebuah NAT dengan action Masquerede sesuaikan dengan out-interface dengan nama VPN yang anda gunakan

/ip firewall nat
add action=masquerade chain=srcnat out-interface=VPN-mikaila

Kemudian buat Layer 7 Protocols ke menu IP–>Firewall–>Layer 7 Protocols, saya memberi nama Youtube

^.+(youtube.com|www.youtube.com|m.youtube.com|ytimg.com|s.ytimg.com|ytimg.l.google.com|
youtube.l.google.com|i.google.com|googlevideo.com|youtu.be).*$

Kemudian tambahkan mangle untuk memasukkan IP ke address list dari Layer 7 Protocol yang telah dibuat tadi.

/ip firewall mangle
add action=add-dst-to-address-list address-list=STREAMING \
    address-list-timeout=5m chain=prerouting layer7-protocol=Youtube \
    protocol=!icmp src-address-list=private-local

Kemudian buat mangle lagi untuk menandai koneksi (Mark Connection)

/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-list=STREAMING \
    new-connection-mark=streaming passthrough=yes src-address-list=private-local

Kemudian buat Mark Routing dari Mark Connection yang dibuat pada tahap sebelumnya

/ip firewall mangle
add action=mark-routing chain=prerouting connection-mark=streaming \
    new-routing-mark=VPN passthrough=no protocol=!icmp src-address-list=private-local

Langkah terakhir yaitu membuat static routing dengan gateway nama interface VPN dan routing mark nama mark routing yang sudah dibuat pada tahapo sebelumnya, seperti pada gambar dibawah ini